Jump to content
과거의 기술자료(읽기 전용): https://tech.devgear.co.kr ×
과거의 기술자료(읽기 전용): https://tech.devgear.co.kr
  • 0

델파이 12 (아테네) IOS기기 지원 관련 (추가 질문입니다)


가을이다

질문

 

안녕하세요.

델파이 12 (아테네) IOS기기 지원 관련하여 답변 주신 내용에 대한 추가 질문입니다.

 

답변주신 내용

iOS 16/17은 델파이 12 아테네 버전에서 개발하고,

iOS 14/15는 델파이 알렉산드리아 11.3을 사용하시기 바랍니다. 

델파이에서 공식 지원에서 iOS 최근 2 개 버전만 있는 배경은 델파이 보다는 애플의 정책 (최신 iOS 버전이 아니면 스토어에서 받지 않음)에 기인하는 면이 큽니다.

이런 이유로 델파이는  늘 새 버전에서 새 iOS를 공식 지원하고 그 이전 버전은 공식지원하지 않는 식으로 진행되고 있습니다. 예를 들어 시드니 버전에서 iOS 새 버전들을 공식 지원하고 그 이전 버전들은 공식 지원에 넣지 않았고, 알렉산드리아에서는 그 다음 iOS 새 버전들만을 공식 지원하는 식입니다.

참고로, 델파이 공식 지원에서 오래된 iOS 버전이 빠졌다고 해서 아예 지원 자체가 안되는 것은 아닙니다. 델파이 기능들은 (애플에서 지원은 중단하지 않았다면) 그대로 남아있고 오래된 버전들과도 호환됩니다. 

 

추가질문

그렇다면 델파이 12 아테네에서 개발된 것을 [앱스토어] 에 올릴 경우..

IOS 기기가 구형인 14, 15 인 사용자들도 검색/다운이 가능하다는 말씀이실까요?

(이것은 단지 애플의 정책에 따라 달라지는 것 뿐인가요?)

[공식지원] 이란 말은, 개발 당시의 mac에 연결된 IOS 버전을 말하는 것 뿐인가요?

이 댓글 링크
다른 사이트에 공유하기

4 answers to this question

Recommended Posts

  • 0

iOS 16용으로 개발한 앱을 14, 15에서 사용이 가능한지는 애플 개발자들에게 물어보면 답이 나오지 않을까 합니다.

저는 모바일 개발을 아예 해보지 않아서 잘 모르겠으나 현재 앱스토어에 앱을 올릴때 ios 16 이상 지원하는 앱만 올릴 수가 있고 내년 4월부터는 ios 17 SDK로 빌드한 앱만 등록이 가능하다고 알고 있습니다.

해당 앱이 하위 호환성이 괜찮다면 ios 15 이하에서도 실행되긴 할텐데 왠만하면 사용자가 ios를 올려야죠. 요즘 누가 iOS 15를 쓰겠어요.

이 댓글 링크
다른 사이트에 공유하기

  • 0

개발된 iOS 앱이 애플 앱스토어에 올라가거나, 올라간 앱이 구형인 14, 15 사용자들에게 검색/다운로드가 되는 것은 이미 잘 아시겠지만, 애플의 정책에 따라서 언제든지 달라집니다. 

개발툴 입장에서 [타겟 플랫폼 공식 지원]이라는 말은 해당 OS 버전을 ‘개발’하는 것을 공식 지원한다는 의미입니다.

개발자 입장에서 명확히 파악하고 싶은 사항으로 생각됩니다. 다음 주 중에 별도로 연락을 드리고 싶습니다. 괜찮으실까요?

이 댓글 링크
다른 사이트에 공유하기

  • 0
On 2023. 11. 21. at 오후 4시 47분, 어드민 said:

개발된 iOS 앱이 애플 앱스토어에 올라가거나, 올라간 앱이 구형인 14, 15 사용자들에게 검색/다운로드가 되는 것은 이미 잘 아시겠지만, 애플의 정책에 따라서 언제든지 달라집니다. 

개발툴 입장에서 [타겟 플랫폼 공식 지원]이라는 말은 해당 OS 버전을 ‘개발’하는 것을 공식 지원한다는 의미입니다.

개발자 입장에서 명확히 파악하고 싶은 사항으로 생각됩니다. 다음 주 중에 별도로 연락을 드리고 싶습니다. 괜찮으실까요?

네 답변 감사합니다. 별도로 연락주셔도 무방합니다!

이 댓글 링크
다른 사이트에 공유하기

  • 0

질의하신 내용과 관련하여 iOS 앱 등록에 관련된 현재 애플의 애플스토어 정책은 다음과 같습니다.

Please note that as of April 2024 all iOS and iPadOS apps submitted to the App Store must be built with a minimum of Xcode 15 and the iOS 17 SDK

따라서, iOS 14와 15용 앱은 현재 시점에는 애플 스토어에 올릴 수 없습니다.

그리고, iOS 17를 최소 타겟으로 지정한 앱을 애플 스토어에 올린다면, iOS 16 또는 그 이하 버전에서는 검색과 사용이 불가한 것으로 알고 있습니다.

 

@가을이다 님의 의견은 사실 "중요한 점을 지적"하고 있다고 생각합니다. 최소 타겟 iOS 버전을 올린다는 것은 그 이하 버전의 iOS 사용자를 포기한다는 의미이기 때문입니다. 그래서 앱의 사용자가 줄어들게 하는 요인이 됩니다. (물론, 새 버전 사용자를 늘린다는 점도 있지만요). 따라서 최소 타겟 iOS 버전을 올리는 것은 쉽게 선택할 수 없고 전략적으로 선택해야 할 문제입니다.

애플의 정책 변화는 빠른 편이고, 그때마다, 당연히 개발자 뿐만 아니라 개발툴 제작사에게도 많은 영향을 주는 것 또한 사실입니다. 하지만, 결국 애플의 정책을 따를 수 밖에 없는 경우가 대부분이고, 그렇게 하는 것이 안전합니다. 애플은 이런 쪽에서 상당히 완강한 면이 있습니다.

그런 이유를 들자면, 오래된 iOS 버전용 앱은 소프트웨어적으로 보안과 성능면에서 취약하고, 그 결과 앱이 깨지거나 장비에 나쁜 영향을 미칠 수 있습니다. 또한, 애플은 장비 제조사이기도 하므로, 화면의 크기 해상도 등도 버전에 따라 달라져서 iOS 앱이 모든 변화에 맞게 완전하게 작동하기도 쉽지 않습니다. 또한, iOS 사용자는 애플이 강력히 추진하는 바와 같이 최신 iOS를 빠르게 받아들이는 경향이 많습니다. 적어도 가지고 있는 장비가 지원되는 버전까지는요. 물론 애플에서 구형 장비에서 작동하는 iOS 버전에 제약을 두기 때문에, (정말 오래된 장비여서) 그 제약을 넘으면 새 장비를 사야하는 상황에 놓이게 될 수도 있습니다. 더 많은 이유들이 있겠지만, 결국은 애플의 기본 정책을 준수하며 앱 런칭 전략을 수립하는 것이 좋습니다.

개발툴 입장에서 드릴 수 있는 답변이 별로 없어서 도움이 될 지는 모르겠습니다만, 참고하시기 바랍니다.

이 댓글 링크
다른 사이트에 공유하기

이 토의에 참여하세요

지금 바로 의견을 남길 수 있습니다. 그리고 나서 가입해도 됩니다. 이미 회원이라면, 지금 로그인하고 본인 계정으로 의견을 남기세요.

Guest
이 질문에 답변하기...

×   서식있는 텍스트로 붙여넣기.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   이전에 작성한 콘텐츠가 복원되었습니다..   편집창 비우기

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

중요한 정보

이용약관 개인정보보호정책 이용규칙 이 사이트가 더 잘 작동하기 위해 방문자의 컴퓨터에 쿠키가 배치됩니다. 쿠키 설정 변경에서 원하는 설정을 할 수 있습니다. 변경하지 않으면 쿠키를 허용하는 것으로 이해합니다.